Degraded performance on browse

Incident Report for Monotype

Resolved

The issue affecting Browse has been resolved. All services are now operating normally. We apologize for the disruption and appreciate your patience while we worked to fix the problem.
Posted Mar 24, 2025 - 16:39 UTC

Monitoring

The issue affecting Browse has been resolved, and we are currently monitoring the situation to ensure stability. We will continue to keep you updated. Thank you for your patience and understanding.
Posted Mar 24, 2025 - 16:24 UTC

Update

Our team is working diligently to implement a solution. We will provide updates as soon as more information is available. Thank you for your patience.
Posted Mar 24, 2025 - 16:04 UTC

Identified

We are aware of an issue causing degraded performance on Browse Page. Our engineers are investigating the cause and working to restore normal service as quickly as possible. We apologize for any inconvenience and will keep you updated.
Posted Mar 24, 2025 - 15:30 UTC

Investigating

We are currently experiencing degraded performance on the Imported Fonts of manage page. Our team is working to resolve this as soon as possible. We apologize for any inconvenience caused and will keep you updated.
Posted Mar 24, 2025 - 14:55 UTC
This incident affected: Monotype Fonts (Browse).