Monotype Fonts and Foundry Platform services Impacted

Incident Report for Monotype

Resolved

The issue affecting Monotype Fonts and Foundry Platform has been resolved. All services are now operating normally. We apologize for any inconvenience this may have caused and appreciate your understanding.
Posted Dec 05, 2025 - 09:33 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 05, 2025 - 09:24 UTC

Monitoring

A fix has been implemented by CloudFlare, and Services are recovering now. We are monitoring the progress, and we will provide an update accordingly.
Posted Dec 05, 2025 - 09:17 UTC

Investigating

Monotype Fonts and Foundry Platform are impacted because of the CloudFlare outage. We are monitoring the progress, and we will provide an update accordingly.
Posted Dec 05, 2025 - 08:50 UTC
This incident affected: Monotype Fonts (Login-SSO, Login-Social Media, DashBoard, Browse, Foundries, Font-Sync, MyLibrary, Web Font Hosting, WhatTheFont, Usage And Reports, Manage) and Foundry Platform (Login, Dashboard, Foundries, Earning Report, Submission, Promotion).