Incident on Foundry Platform

Incident Report for Monotype

Resolved

The issue affecting Foundry Platform has been resolved. All services are now operating normally. We apologize for the disruption and appreciate your patience while we worked to fix the problem.
Posted Mar 27, 2026 - 16:36 UTC

Monitoring

We have applied a fix, and the issue affecting Foundry Platform has been resolved. We are currently monitoring the situation to ensure stability. We will continue to keep you updated.
Posted Mar 27, 2026 - 16:01 UTC

Investigating

We are aware of an issue causing an outage on the Foundry Platform. Our engineers are investigating the cause and working to restore normal service as quickly as possible. We apologize for any inconvenience and will keep you updated.
Posted Mar 27, 2026 - 15:49 UTC
This incident affected: Foundry Platform (Login, Dashboard, Foundries, Earning Report, Submission, Promotion).