Experiencing issue with Enterprise Application
Incident Report for Monotype
Resolved
The issue has been resolved.
Posted Aug 17, 2024 - 14:39 UTC
Investigating
We are having issue with login on enterprise.monotype.com. Our engineering team is currently investigating the issue.
Posted Aug 17, 2024 - 14:06 UTC
This incident affected: Monotype Fonts (Login-SSO, DashBoard, Browse, MyLibrary, Usage And Reports, Manage).