The issue has been resolved, Thank you for your patience and understanding.
Posted Jun 17, 2025 - 16:16 UTC
Investigating
We are currently experiencing issues with the Manage-Usage page Our team is working to resolve this as soon as possible. We apologize for any inconvenience caused and will keep you updated.
Posted Jun 17, 2025 - 15:28 UTC
This incident affected: Monotype Fonts (Usage And Reports).