We’re currently experiencing issues.

Incident Report for Monotype

Resolved

AWS has resolved all issues with us-east-1, we have been monitoring and have seen no additional impact and we also are marking this incident as resolved.
Posted Oct 20, 2025 - 23:13 UTC

Monitoring

Most AWS services and our partners have recovered, we are seeing all our systems operating normally at this time and we will continue to monitor for any further impacts.
Posted Oct 20, 2025 - 22:20 UTC

Update

Continued issues are being experienced due to ongoing issue with Amazon Web Services (AWS) US-East-1. We will provide updates as they become available.
Posted Oct 20, 2025 - 21:28 UTC

Update

AWS US-East-1 is experiencing a major outage impacting our services. We’re actively monitoring status updates from our cloud provider and will share new information as soon as it becomes available.
Posted Oct 20, 2025 - 15:15 UTC

Identified

AWS US-East-1 is experiencing a major outage impacting our services. We’re actively monitoring status updates from our cloud provider and will share new information as soon as it becomes available.
Posted Oct 20, 2025 - 14:55 UTC
This incident affected: Monotype Fonts (Browse, Font-Sync, MyLibrary, WhatTheFont).